myBUSCH-JAEGER | MyBuildings portal is not available
Incident Report for
myBUSCH-JAEGER | MyBuildings Cloud Status Dashboard
Resolved
This incident has been resolved.
Posted
Jul
06
,
2026
-
23:25
CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jul
06
,
2026
-
23:18
CEST
Investigating
myBUSCH-JAEGER | MyBuildings portal services are not available. We are currently investigating the issue.
Posted
Jul
06
,
2026
-
22:25
CEST
This incident affected: myBusch-Jaeger / myBuildings Portal Cloud.
×
Subscribe to Incident
Subscribe to updates for
myBUSCH-JAEGER | MyBuildings portal is not available
via . You'll receive .