Welcome Services are under investigation.

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 09:16 CET

Investigating

Some customers may have experienced difficulty using Welcome (IP) with its remote connectivity. Our team is investigating the incident.
Posted Jan 15, 2026 - 11:33 CET
This incident affected: Welcome (Welcome, Welcome IP) and ProService portal.